Sign in to follow this  
Followers 0
AnthonyM

Fire Mage rotation help

10 posts in this topic

Hello everyone, I have been playing fire for a while and struggling with DPS after combustions. I know my invokers energy could be up a lot more but I don't think that is all of my issues. Here are some logs and my armory link:

 

http://www.worldoflogs.com/reports/rt-euwqzr3e078eb8rh/details/2/

http://us.battle.net/wow/en/character/stormreaver/Optech/simple

 

 

I have bursted for 500 - 600k but then drop to 110-120k afterwards. I have no idea why. I am out bursting other mages in my guild at times but they always out DPS me by a ton. So, I believe my opener isn't the issue and combusting. It's gotta be just regular rotation that I am having an issue with. I have read the guide on here but maybe I am just not getting it (even though its clean and clear)

 

 

Any thoughts would be helpful. Thanks a bunch.

Share this post


Link to post
Share on other sites

I'm looking at Jin'rokh, since that is the most trivial boss to analyze.

 

You are moving too much. Half of the Scorch casts could have been Fireballs, dealing double damage and you could have do the "Pyroblast trick" when you queue up a Pyroblast! and a Heating Up! and then you cast Fireball and immediately using up the Pyroblast!. Also with the Cold Snap combo mentioned in the Mage style topic of this forum, it is trivial to avoid moving due to Ionization.

 

Mage Bomb uptime could be better, but it's okay.

 

46k combustion ticks are very low on that boss. Were you standing in the water while combusting and before it? It is very important to only combust after a high Pyroblast crit, preferably when you have trinket procs.

 

Mon, 59% Invocation uptime is bad. There is no excuse for that ^^ You miss 15% extra damage on all spells. That IS a big issue, like you didn't have it on half of the heroism uptime and when you combusted.

 

I cannot see Molten armor on you at all oO

 

No usage of potions, not even at the pull.

3 people like this

Share this post


Link to post
Share on other sites

Just agreeing with everything Oltier said above. smile.png

Invocation uptime is a huge deal.

 

I cannot see Molten armor on you at all oO

 

 

I have this problem on all the logs Oltier.  Under Buffs Cast, I see Molten Armor for a # of casts with 0% uptime always?  Thoughts?
 

Share this post


Link to post
Share on other sites

mmm. I might have overlooked something. I just pointed out it might have been an issue as well, but if he is sure that the armor was on, then excuse me :D

Share this post


Link to post
Share on other sites

No, no,  I don't know is what I was getting at.  Do you have a link to a log showing the buff up?  I can't find any logs showing the buff active properly (on any logs).  I guess that's what I'm asking now.  And yes make sure it's up if it isn't smile.png

Share this post


Link to post
Share on other sites

I believe you that it was up 90%, but it still could be higher. smile.png

Still not seeing the results I would like unsure.png

Share this post


Link to post
Share on other sites

Still not seeing the results I would like unsure.png

If you have fresh logs, I could have a look at them to see if anything improved/changed :)

Share this post


Link to post
Share on other sites

Still not seeing the results I would like unsure.png

 

I looked at all the lots, and found not enough uptime on Pyromaniac (~70% on Megaera, 75% on Ji-kun) which means you're not keeping your Living Bomb up on your target. It's very easy to get tunnel vision trying to find that perfect string of crits and let it fall off, crippling everything you so carefully set up.

 

Your damage is respectable for 532, you just need to drill yourself more to get that last few %.

Edited by Tarazet
1 person likes this

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.