Sign in to follow this  
Followers 0
Toffees

Forum pages shrinking on iPad

23 posts in this topic

Hey guys

I've recently noticed that when reading the forum on my iPad, the pages start to shrink. It's something to do with the adverts at the bottom of the screen. It doesn't happen all the time but its kinda annoying because it keeps resetting when you scroll the page and then starts to shrink (zoom out) as you start reading

I'm running iPad OS ver 6.13

1 person likes this

Share this post


Link to post
Share on other sites

Hello,

Thanks for notifying us. Could you please provide us with a screenshot of the issue? The idea is that we need to identify the ads causing the problem, so that we can remove them. Vlad has an iPhone, so I'll get him to browse the forums too, hoping he will stumble upon the same ads.

Share this post


Link to post
Share on other sites

This is happening all over the site for me on my ipad. The two I've noticed today when reading the SOO guide are Mazda cx5 and Meet the new windows 8 adverts. I often encounter the problem on the class guide pages, especially ones with very long pages, such as the disc priest rotation guide.

Share this post


Link to post
Share on other sites

Ahh come on guys this is getting ridiculous. The ad's are getting worse with the latest being Cathay pacific. It makes reading posts on any iOS based device a pain in the arse as the page keeps moving as you're reading it. When you want to reply you spend a minute playing 'Hit the reply button'. Please get it fixed ASAP as it makes reading the problems totally annoying

Share this post


Link to post
Share on other sites

Sorry, I totally forgot to check that thread (I got married on the 21st of september and that was a pretty big distraction tongue.png). I'll ask our account manager at Intergi to take a look at the screenshot and get that fixed.

Share this post


Link to post
Share on other sites

Hi Damien

Congrats on the wedding!!! Just to make you aware that the problem is still here. It's not related to the adds, it's related to the advert overlay code that places the advert at the bottom of the display.

Matt

Share this post


Link to post
Share on other sites

Hi Damien

Congrats on the wedding!!! Just to make you aware that the problem is still here. It's not related to the adds, it's related to the advert overlay code that places the advert at the bottom of the display.

Matt

Thanks! smile.png

I don't have an iPad, so that makes it very hard for me to investigate. Now, you seem to be knowledgeable, since you figured out that the overlay code is causing the problem. I don't know if it's possible o do that from the iPad, but could you try and save the content of the DOM (from the <html> root). I think that if I had that, I'd be able to investigate. Maybe "saving the page as" would do the trick.

The thing is that I reported the problem to our ad agency, but without details I know that they won't find it. So anything helps.

Share this post


Link to post
Share on other sites

It's still happening and getting worse:

http://i935.photobucket.com/albums/ad199/liofa73/image_zps62dda1df.jpg

http://i935.photobucket.com/albums/ad199/liofa73/image_zps977dbb9e.jpg

http://i935.photobucket.com/albums/ad199/liofa73/image_zps5090d1e2.jpg

Your ad people certainly won't care, but as many more people are using mobile devices, I hope you can get it sorted.

Thanks for the screenshots. It's really weird, I mean in the first screenshot there are like 6 ads, which should never happen. From the previous messages, I thought it was the bottom ad that was like expanding or attaching itself to the bottom. I've sent another e-mail to get that removed.

Share this post


Link to post
Share on other sites

Yup it's mainly the bottom one, it sort of keeps flashing and as it does so the forum or page text constantly shrinks. I think the side ads grow as well. Even when the page has loaded the ad at the bottom starts to shrink the page, so if you are just about to click a link you sort of miss. Very strange. :)

Share this post


Link to post
Share on other sites

Does anyone know of an app that let's me analyse served pages to my iPad? Is there a Safari debug mode or similar tools like chrome/IE?

Share this post


Link to post
Share on other sites

Does anyone know of an app that let's me analyse served pages to my iPad? Is there a Safari debug mode or similar tools like chrome/IE?

There is, but you need to use your iPad or iPhone through your Mac, after connecting it on USB, I think. I've installed the iOS SDK on my Mac, and I'll try to debug this mobile browsing issue. First time I tried browsing the website from the iOS simulator, I was greeted by a huge popup, not cool tongue.png

Share this post


Link to post
Share on other sites

Ok, so I've spent some time this morning trying to track down this issue, to no avail. I used the method described here: http://webdesign.tutsplus.com/tutorials/workflow-tutorials/quick-tip-using-web-inspector-to-debug-mobile-safari/

I used a UK-based proxy to make sure I would get UK ads on my iPhone simulator, but I didn't get the ones that resize the page, sadly sad.png

Share this post


Link to post
Share on other sites

I've been using http://www.browserstack.com/ to simulate various versions of IPads and phones etc (great site BTW) and havent been able to replicate whats happening on my actual iPad. The next step for me is to link my iPad up to a Mac VM and capture what my iPad is seeing in debug mode.

Share this post


Link to post
Share on other sites

Hey Damien,

Id just like to point out this is still a very obnoxious problem. As others say, whenever I scroll along the forum posts (not so much general forums but actual posts) the banner adds that attempt to place themselves around the bottom of the screen consistently move and slightly resize the forum page. It also seems to lag my iPod a large amount.

I will get my camera tomorrow and make a video to show you the issue I'm getting. Mainly it's the futureshop and Walmart add, but I don't think those are the specific ones, it's likely the ad displayer to begin with. It's also been trying to place itself on the bottom of my screen, and slowly scroll down a tad on its own, which it does several times until it randomly decides to stop.

Share this post


Link to post
Share on other sites

Lol as soon as I try to replicate this and give you guys an example of what I mean, I can't seem to get the Walmart/Futureshop ads that have overlay to show up anymore. Everything works fine when the overlay isn't around though, I can confirm that much!

Share this post


Link to post
Share on other sites

I don't know if you've applied a fix recently in attempt to solve the issue but the overlay thing of the Walmart ad is no longer messing around with my screen. It seems to be fixed, ill let you know if it starts to act up again!

Share this post


Link to post
Share on other sites

I don't know if you've applied a fix recently in attempt to solve the issue but the overlay thing of the Walmart ad is no longer messing around with my screen. It seems to be fixed, ill let you know if it starts to act up again!

Well, I bugged our ad agency so many times about this that maybe they finally figured it out tongue.png Often, these are not ad campaigns that they are running themselves, but rather some non video game related ads that they get from a 3rd party partner. So when something goes wrong with these ads, it is very difficult for them to track things down. In any case, I am confident that as time goes by, we will see less and less of these issues. Thank you for following up on the problem. I can't replicate it here in France because I never get these ads (even when I use a proxy).

Share this post


Link to post
Share on other sites

I'm somewhat glad I was so that I could help! (If my posts did infact help, otherwise atleast I'm able to provide information that its working now) Now the only thing I need left to maximize my mobile experience is not be terrible at clicking the "x" to close the ad, and get a newer model iPod since mines like 4 years old and getting slow :(

1 person likes this

Share this post


Link to post
Share on other sites

I'm somewhat glad I was so that I could help! (If my posts did infact help, otherwise atleast I'm able to provide information that its working now) Now the only thing I need left to maximize my mobile experience is not be terrible at clicking the "x" to close the ad, and get a newer model iPod since mines like 4 years old and getting slow sad.png

Well, there shouldn't really be an ad that needs closing. We don't normally allow these ads to be run on the website and our agency is aware of that.

Share this post


Link to post
Share on other sites

Ah, well thats what those banner ads are, they pop up on the bottom of your screen and I gotta close them off each time if they're in my way. Though with this fix its not so horrible anymore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.