Sign in to follow this  
Followers 0
grissle02

Can't Mount or Switch to Travel form when in Bear or Cat.

5 posts in this topic

Hey all,

   Yesterday halfway through the day i started experiencing something weird. I started getting the weird message "you are in shapeshift form" when ever i tried and hitting travel form or tried mounting up (and Dreamwalk) from Bear or Cat form.. Originally i thought it might be a bug in a add-on.. so i went into my options and disabled them all to see if it went away.. And nope it still was the case. so the next step i took was deleting my Cache and WTF folders.. And nope its still the same.. Then i thought i t might be a bug with the hidden Ursoc skin.. so i switched back to one of the regular skins for guardian.. nope.. 

  I went on the Druid discord + asked other druids in my guild and it seemed like nobody else was having this issue.. Has anyone else have or had this issue and know what could be causing this? I submitted a bug report but who knows if it will ever get seen.. Anyways thanks for you time and look forward to hearing back from you guys.

Share this post


Link to post
Share on other sites

Did you use a macro to disable autoshapeshift?

Re-enable it by:

/console autoUnshift 1

 

EDIT:

Typical macro people use to use Healing Touch when they have Predatory Swiftness is:

 /run SetCVar("autoUnshift",0)
/cast Healing Touch
/run SetCVar("autoUnshift",1)

Edited by Archimage

Share this post


Link to post
Share on other sites

and plus its happening when i am out of combat not using macros.. but i just went threw and took the one marco out that i use and still nothing while i am sitting in Dalaran in bear form.. My travel form button, mount up button and dreamwalk are all grayed out and cant click.. and if i do it says "You are in shapeshiftform"

Share this post


Link to post
Share on other sites

I thought it was normal. I have no problem switching from a form to another, but whenever I'm in cat, bear, or stag (stag, not travel) form I can't mount up.

 

I added some cancelauras to my mount macro, so it works fine now, but yeah I've always had that (since I've started playing at least, which was 40 days ago).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.