brendanarman

Felguard turning off threateNing Presence

Sign in to follow this  

2 posts in this topic

Hey guys, so I'm leveling a Demonology warlock and I just got my felguard only to find out  he has this thing called threatening presence on. I can't seem to find where to turn it off. I used a macro that turned it off but he just turns it back on. Any help? Thanks

Share this post


Link to post
Share on other sites

You should right-click the icon in order to turn off autocast before cancelling the ability.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.