Jump to content

Stuck on quest HELP!

Recommended Posts

At the last chapter of the "Embers of Neltharion" questline I have to talk to Alexstraza in Valdrakken to get the "Symbol of Hope" quest, but she is nowhere to be found and there is no information on YouTube or Google. I've tried to re-log, disabling all of my addons, going to another zone and then re-logged and I've tried to restart my PC. I've also made a ticket but as always that didn't help much : /

Does anyone know why she's not there? Or at at least have any ideas? ty

Stuck on quest.PNG

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...