Aryvai

There isn't a new Hexweave Spell when Hitting Tailoring 700?

6 posts in this topic

I've recently hit tailoring 700 and I did not recieve the new hexweave cloth spell that allows for three charges. At first, I thought I just had to wait for the daily cooldown to end. I did that and still no new spell. Does anyone know if I am supposed to do something specific to get the hexweave cloth spell with three charges?

Edited by Aryvai

Share this post


Link to post
Share on other sites

I've searched this thoroughly online and I have found a lot of players saying that the 3 charge feature once you hit 700 in any profession has been removed from the live game. However, I have yet to see a patch note or a blue post about this. Can anyone confirm that this is true?

Share this post


Link to post
Share on other sites

Nevermind! I found the confirmation I needed.

 

What did ya find out

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Bullkhacki
      I have submitted multiple tickets, reported a bug and been to every forum and neither Blizzard or anyone seems to have an answer for my issue. Weeks ago when the Nether Disruptor first became active, I received the Armorcrafter's Commendation and completed the quest chain to craft my first legendary item using Leatherworking.  The next time the Disruptor was up, I began the quest chain for a second time, but never completed the quest chain and decided to change professions to Tailoring so I can craft the legendary tailoring item. After reaching skill level 800, I waiting for the Disruptor to become active, I received a new Armorcrafter's Commendation and went to hand it in to Eliezer Hammerbeard, but instead of it starting the Tailoring quest, he says, "Hold on just a moment. Let's finish the armor we're already making first." It appears my toon is stuck on the prior quest from when I had Leatherworking, however, I do not show the quests in my quest log to abandon it and there seems to be no way to reset this. I've even waited for the Disruptor to come back up again the following week and still the same message. This appears to be the same message I get time and time again (3 times and counting). Is anyone else having this issue or know what I can possibly do? Appreciate the help!!